I cannot install the app, why?

SmartHalo is compatible with iPhone iOS 9 and more recent, as well as Android 4.4.4 and more recent. Make sure you have the appropriate phone and that its operating system is up to date. SmartHalo also requires a data connection (at least 3G).

Was this article helpful?
0 out of 0 found this helpful